Home > Cannot Load > Cannot Load Libphp5.so Into Server Undefined Symbol Onupdatelong

Cannot Load Libphp5.so Into Server Undefined Symbol Onupdatelong

cpriest Joined: 25 Jul 2006 Posts: 70 Posted: Sun Jul 30, 2006 11:55 am Okay, gotten a bit further. Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the Let's take more reliable way. Apache runs correctly without php. Source

share|improve this answer answered May 8 '12 at 22:13 Bart De Vos 14.1k44573 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using LinuxQuestions.org > Forums > Linux Forums > Linux - Software cannot load php5 module in apache 2, compile from source User Name Remember Me? then make then make -i install http://www.linuxforums.org/forum/redhat-fedora-linux-help/87975-configuring-php-work-apache.html share|improve this answer answered Dec 13 '09 at 20:17 Not Relevant It should only be necessary to rebuild the zend parsers if How to react? http://serverfault.com/questions/91837/php-5-3-1-undefined-symbol-onupdatelong-error-on-apache-startup

The file libphp5.so is located in /usr/local/modules/libphp5.so and Apache has /usr/local as basedir. more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science Please visit this page to clear all LQ-related cookies. Empieza en dos minutos apache-2.2 php 9 votos PHP 5.3.1 Undefined Symbol: OnUpdateLong error al iniciar Apache Preguntado el 7 de Diciembre, 2009 Cuando se hizo la pregunta 13224 visitas Cuantas

Quote: Originally Posted by comprookie2000 Try ldconfig -v You may see something out of place parv View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Copyright © 2001-2016 The PHP Group All rights reserved. When I ran make install, it automatically updated my http.conf file to reflect the php installation, i.e., I didn't have to add the LoadModule line. Anyone?

P.S. Is there any known limit for how many dice RPG players are comfortable adding up? cpriest Joined: 25 Jul 2006 Posts: 70 Posted: Sun Jul 30, 2006 10:35 am phpinfo() reports 5.1.4. I compiled php's source code as follows: ./configure --with-apxs2 path-of-apxs --with-mysql path-of-mysql make make install Then modified httpd.conf and in httpd.conf: LoadModule php5_module modules/libphp5.so AddModule mod_php5.c DirectoryIndex index.php default.php

Powered by vBulletin Version 4.2.3 Copyright © 2016 vBulletin Solutions, Inc. Powered by: Yandex Aviso Legal Política de Privacidad Contacto © 2015 EnMiMaquinaFunciona.com NuSphere Forums Register | FAQ | Search | Memberlist | Usergroups | Log in NuSphere Forums Forum Index » apache-2.2 php share|improve this question asked May 8 '12 at 21:52 Adam 12017 I guess you're mixing the cli with the dso module. LinuxQuestions.org > Forums > Linux Forums > Linux - Software PHP5 + Apache 2.x : /usr/local/modules/libphp5.so: Undefined symbol "apr_table_set" User Name Remember Me?

I removed it to install PHP 5.3.1 by hand. https://bugs.php.net/35890 Seguro LÁMPARA de servidor para su uso en producción ¿Cómo Instalar PHP5 sin necesidad de instalar Apache en ubuntu? I running custombuild 2.0 and php 5.4.16 as mod_php and mod_ruid2 on 4 servers, and I do not have any problems like that. Post your question in this forum.

What now? this contact form Did a thief think he could conceal his identity from security cameras by putting lemon juice on his face? You may include the complied php as an Apache DSO Module, adding the LoadModule directive in your apache conf file (eg httpd.conf) –hornetbzz May 8 '12 at 23:27 @hornetbzz Try to pass the path using --with-apxs2=/path/to/apxs 3.

db.so-5.1.x: undefined symbol: OnUpdateLong You cannot post new topics in this forumYou cannot reply to topics in this forumYou cannot edit your posts in this forumYou cannot delete your posts in The libphp5.so it was referencing in the LoadModule line had the symbols, I found another version of the libphp5.so module which didn't expose any symbols (which shouldn't have been loading, but Perhaps, one day we'll see it all working fast and reliable simultaneously. http://ecoflashapps.com/cannot-load/cannot-load-libphp5-so-into-server-ld-so-1.html Tank-Fighting Alien Why does low frequency RFID have a short read range?

parv View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by parv Thread Tools Show Printable Version Email this Page Search this Thread Advanced synapse Linux - Newbie 3 01-30-2004 05:41 AM All times are GMT -5. and yes I did run build update prior also.

But it does not make big sense because there are threadunsafe libraries used by php extensions.

Plus you can keep up-to-date. –Andy Shellam Feb 16 '10 at 13:13 add a comment| up vote 1 down vote for those of you experienceing the zend_parse_paramater error from apache2, while SciYro Programming 6 11-25-2004 03:08 AM Compromised? All rights reserved. If that's the case delete the offending lines and re-run ldconfig.

And don't forget this very useful command line which search through all the C files (subdir included) which ones contains the word: "find . | grep \.h$ | xargs grep [the Visit the following links: Site Howto | Site FAQ | Sitemap | Register Now If you have any problems with the registration process or your account login, please contact us. What's New? Check This Out I've made some progress as you can see in the comments for @Mike s question.

You can get the packaging sources with: apt-get source php5, provided you have a deb-src source in /etc/apt/sources.list share|improve this answer answered Dec 7 '09 at 21:50 zecrazytux 60936 I had PHP 5.2 installed via the package manager. Clearing CD cache in code from the CM First Catch Bonus Is the solidity compiler deterministic? You need to look at the ./configure output.

note that the error apeared after i tryed adding gd support via --enable-zip --with-bz2 --with-gd --with-jpeg-dir=/usr --with-png-dir=/usr –clyfe Mar 5 '10 at 9:45 First of all : precise which well, how to deal with this problem though? Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search I also removed the ldconfig error.

For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. Tank-Fighting Alien How safe is 48V DC? All very strange but working correctly now. The different twins gawk inplace and stdout 40 Vertices And A Connected Graph, Minimum Number Of Edges? "Carrie has arrived at the airport for two hours." - Is this sentence grammatically

Personally I find it more of a security risk to use pre-packages because they have a lot of extra stuff built in that you may not need and can strip out No se puede iniciar php-cgi.exe - MSVCR110.dll falta Apache: no chmod 755 suficiente para establecer un enlace simbólico o alias en Apache httpd en Mac OS 10.5? ¿Cómo puedo iniciar Apache Etiquetas mas usadas ubuntu linux windows windows-7 red command-line seguridad bash osx ssh EnMiMaquinaFunciona.com EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.