Home > Cannot Load > Cannot Load /usr/lib/httpd/modules/libphp5.so

Cannot Load /usr/lib/httpd/modules/libphp5.so

Results 1 to 5 of 5 Thread: Cannot load /usr/lib64/httpd/modules/libphp5.so into server Tweet Thread Tools Show Printable Version Subscribe to this Thread… Search Thread Advanced Search Display Linear Mode Switch Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the I installed the main services (httpd and mysql) with the commands: Yum install httpd mysql-server gcc The installation went smoothly. LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie [SOLVED] LoadModule php5_module modules/libphp5.so User Name Remember Me? have a peek at this web-site

about "everything is ok" i mean httpd restart. Not the answer you're looking for? thanks.ayekat wrote:Why use some potentially outdated/wrong, third-party tutorial rather than the fine Wiki?(PHP 5 has recently been moved to the AUR, and that article there is from 2014) Offline #4 2016-02-18 See # their respective man pages for detailed information. # # * The binary is called apache2. http://stackoverflow.com/questions/20510831/apache-cannot-load-modules-libphp5-so-into-server-when-i-installed-php5-gd

Fedora 19. –Kae Verens Dec 11 '13 at 12:53 didn't work for me (although, problem is with libphp7, not 5). any idea please ? Starting httpd: httpdyntax error on line 218 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib64/httpd/modules/libphp5.so into server: libdb2.so.1: cannot open shared object: No such file or directory. The time now is 19:46.

share|improve this answer answered Dec 11 '13 at 7:56 Michael Tabolsky 2,083198 add a comment| up vote 0 down vote yum remove httpd yum clean all Step1: install fedora 19 Step2: How can I declare independence from the United States and start my own micro nation? If # your system is serving content from a sub-directory in /srv you must allow # access here, or in any related virtual host. Options FollowSymLinks AllowOverride None Require To start viewing messages, select the forum that you want to visit from the selection below.

If it's been deleted, that would certainly explain why you don't have web content. Just speculating now but it looks like that Apache environment was built on a somewhat dirty system (custom made changes to system libs, etc.). If you intend to place this on an NFS (or otherwise network) # mounted filesystem then please read the Mutex documentation (available # at ); # you will save yourself a http://www.dbforums.com/showthread.php?1698970-Cannot-load-usr-lib64-httpd-modules-libphp5-so-into-server When I start apache2 everything is fine, but when enabling php5 module and restarting apache2 I get this error: ERROR: *** Restarting web server apache2 [fail] * The apache2 configtest failed.

Install it (from this SO question): sudo apt-get install libapache2-mod-php5 share|improve this answer answered Oct 12 '14 at 12:23 muru 70.7k12127179 It works. but by web site still results white page, i mean nothing. Advertisement dBforums Brief Subscribe to dBforums Brief to receive special offers from dBforums partners and sponsors Top Helpers healdem - 59 mark.b - 55 Pat Phelan - 54 ranman256 - 23 Subscribed!

mona is not in the sudoers file. http://www.centos.org/forums/viewtopic.php?t=28672 For example do you have LIBPATH set, etc? Registration is quick, simple and absolutely free. Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.

Thanks to everyone. Check This Out How do I start apache so that it takes new compiled version of soap and curl. Someone can tell me why it failed? Can I hint the optimizer by giving the range of an integer?

Also, check out apache log. These should be managed by using our # helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. Last edited by TB0ne; 09-22-2011 at 06:27 PM. Source Also you should not change links in /usr/lib, like the libXpm.a symbolic link.

More... I was just trying to install openssl, but copied and pasted the whole command by accident. Then I installed php 5.2.14 from source code. # ./configure # make # make install All code was compiled and no warning was generated.

when i tried to restart httpd i received this error: Starting httpd:[warn] module php5_module is already loaded, skipping i found that there is a config file /etc/httpd/conf.d/php.conf that contains : "

asked 2 years ago viewed 20018 times active 5 months ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Related -2How do I load PHP 5.4.3 with Apache 2.2.3?0SVN with Select 2D data in a certain range SMS verification, is it secure? But I bet there are other issues if it is now running php7.0 where as it was before running php5. You are currently viewing LQ as a guest.

Any way to color lines in a Line command? Quote: Originally Posted by ahmadirad File does not exist: /var/www/html/web Ok...is that your DocumentRoot directory?? How to react? have a peek here And the error.log wasn't there.

ramonlucas27th October 2010, 04:53 PMI think I found the flaw. It contains the # configuration directives that give the server its instructions. # See http://httpd.apache.org/docs/2.4/ for detailed information about # the directives and /usr/share/doc/apache2/README.Debian about Debian specific # hints. # # Can I use that to take out what he owes me? Are you new to LinuxQuestions.org?

more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science Please help Log in to reply. Error still the same ./apachectl start httpd: Syntax error on line 121 of /usr/fs615web/apache-2.2.20/conf/httpd.conf: Cannot load /usr/fs615web/apache/modules/libphp5.so into server: \t0509-022 Cannot load module /usr/fs615web/apache/modules/libphp5.so.\n\t0509-150 Dependent module /opt/freeware/lib/libgd.a(libgd.so.2) could not be loaded.\n\t0509-152 Due to the use of environment variables, in # the default configuration, apache2 needs to be started/stopped with # /etc/init.d/apache2 or apache2ctl.