Home > Cannot Load > Cannot Load /usr/libexec/apache2/mod_jk.so

Cannot Load /usr/libexec/apache2/mod_jk.so

qpoisson commented Jul 8, 2016 Alos tried "sudo make install LIBEXECDIR=/opt/mod_wsgi", similar error: httpd: Syntax error on line 68 of /private/etc/apache2/httpd.conf: Cannot load /opt/mod_wsgi/mod_wsgi.so into server: dlopen(/opt/mod_wsgi/mod_wsgi.so, 10): Library not loaded: The first thing to do is to open /Applications/Utilities/Console.app and see what kind of messages you get when you restart apache. Example: ... ... (Optional) Configuring Tomcat to use the Ajpv13 protocol mod_jk can use either the original Ajpv12 protocol or the newer Ajpv13 protocol. Here are some details that might have slipped under the radar1. http://ecoflashapps.com/cannot-load/cannot-load-usr-libexec-apache2-mod-dav-svn-so.html

Community. asked 5 years ago viewed 165 times active 5 years ago Related 0Why I am getting “Problem loading the page” after enabling HTTPS for Apache on Windows 7?3Installing mod_wsgi into apache2 How can a Cleric be proficient in warhammers? You can check this with $APACHE_HOME/bin/httpd -l. https://discussions.apple.com/thread/1528648?start=0&tstart=0

Also note the virtual host setup is new in Tomcat 3.2 - this example won't work with Tomcat 3.1. . . good idea anyway in case compilation output from older OS version was laying around.

I did a lot of digging too, but I must have been digging in the wrong places. Chances are that if you are getting these errors and you obtained Apache as a binary distribution, that APXS is not configured correctly for your system. Your best bet is to get the Apache source from http://httpd.apache.org and build it yourself. mod_jk should fix that.

See README.hpux located in TOMCAT_HOME/native/mod_jk/apache1.3 for more information. mhh..I rebuilt everithing and I copied your shema, but it is still returning BAD ARCHITECTUREJan 17 19:00:08 f org.apache.httpd[28621]: httpd: Syntax error on line 520 of /private/etc/apache2/httpd.conf: Syntax error on line You could also try searching the mailing list archives for "mod_jk" or look at the source.Q. http://blog.lo-fi.net/2007/10/leopard-for-web-developer-installing.html Make sure that these are set according to your installation.

Possible log levels are debug, info, error and emerg, but info should be your default selection. A. The build will seem like it goes ok if you're not in the "native" directory, but you get the error you mentioned2. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

native$ ./configure CFLAGS='-arch x86_64' APXSLDFLAGS='-arch x86_64' --with-apxs=/usr/local/apache/bin/apxs share|improve this answer answered Jul 8 '13 at 4:51 thiyag 214 add a comment| Your Answer draft saved draft discarded Sign up or However, the error your getting is what you get when the module is not built correctly. If you install a mismatched mod_jk.so, $APACHE_HOME/bin/apachectl configtest will warn you. But the documentation for configuring mod_jk is abundant.

Posted by Eric at 11:45 PM Labels: Java, Leopard, Mac, Tomcat 25 comments: Anonymous said...

ngbgithub commented Oct 15, 2015 For whatever it's worth-- I had the same problem after upgrading to El Capitan, and using the suggested workaround of explicitly specifying the location of mod_wsgi.so Check This Out See README.solaris located in TOMCAT_HOME/native/mod_jk/apache1.3 for more information. Check permissions. Program to check whether two strings are anagrams of each other 40 Vertices And A Connected Graph, Minimum Number Of Edges?

Browse other questions tagged apache-2.2 or ask your own question. If you are using EAPI, try adding -DEAPI to the apxs command after mod_jk.so. Baden Württemberg Ticket usage Simple Python job vacancies downloader Why does low frequency RFID have a short read range? http://ecoflashapps.com/cannot-load/cannot-load-usr-libexec-apache2-mod-wsgi-so.html jheasly commented Oct 15, 2015 When I ran $ mod_wsgi-express install-module I got the same error: IOError: [Errno 1] Operation not permitted: '/usr/libexec/apache2/mod_wsgi-py27.so' And @GrahamDumpleton's method above to get the path

Clearing CD cache in code from the CM This is my pillow Can Egyptian citizen visit Armenia on valid USA visa? If you want to enable System Integrity Protection again, reboot with cmd-R and go into terminal as described above and then write: csrutil enable Regards, Ulf This was referenced Feb 28, Find out whether your Apache has EAPI support.

To configure Tomcat to generate the Apache auto-configuration add the following block to your TOMCAT_HOME/conf/server.xml file after . That's it, you can now start Tomcat and Apache

MacBook Pro 17, Mac OS X (10.4.11), 4 GB RAM, 160 GB HD Posted on May 21, 2008 3:05 AM Reply I have this question too by icfantv,Solvedanswer icfantv Level 1 Many thanks.However the link to download the .25 version is brokenhttp://tomcat.apache.org/connectors-doc/can you publish your src and binary module please? 1/17/2008 4:56 PM Eric said... What you need to do is replace these lines:mod_jk.la: $(APXS) -c -o [email protected] -Wc,"${APXSCFLAGS} ${JK_INCL}" "${JAVA_INCL}" "${APXSLDFLAGS}" mod_jk.c ${APACHE_OBJECTS}with these:mod_jk.la: $(APXS) -c -o [email protected] -Wc,"${APXSCFLAGS} -arch x86_64 ${JK_INCL}" "${JAVA_INCL}" "${APXSLDFLAGS} -arch Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the

no checking for apxs... /usr/sbin/apxs checking for gcc... mod_jk Binaries Binaries for mod_jk are available for several platforms in the same area as the Tomcat Binary Release. Not the answer you're looking for? http://ecoflashapps.com/cannot-load/cannot-load-usr-libexec-apache2-mod-bonjour-so.html Any way to color lines in a Line command?

Reboot your system and then manually remove any mod_wsgi .so in modules directory and then try and reinstall. Where can I get more information? Documentation is also available on the Apache Jakarta web site for Tomcat at http://jakarta.apache.org/tomcat/jakarta-tomcat/src/doc/index.html. Not the answer you're looking for?

Definitions and Terminology In this document I am going to use a few terms, so let's define them: Term Meaning Worker Process A worker is a tomcat instance that is running no checking for suffix of object files... For others, the binary distribution of mod_jk offers simpler installation. What's that message about 'garbled DSO ?' A.