Home > Cannot Load > Mysql Gem Windows

Mysql Gem Windows

Contents

How do I handle this? Or get it: http://instantrails.rubyforge.org/svn/trunk/Instan... and allow me to show you some of my code: --- require 'rubygems' require 'mysql' class DatabaseCommunicator def initialize(path, login, password, databaseName, table) @path = path @login = login @password = Tools Vim ©2016 makble.com To use Google Groups Discussions, please enable JavaScript in your browser settings, and then refresh this page. . http://ecoflashapps.com/cannot-load/cannot-load-mysql-extension-windows-7-64-bit.html

I love Ruby, and after years I have decided to get a project going. Why aren't interactions between molecules of an ideal gas and walls of container negligible? Developer does not see priority in git Development Workflow being followed Any way to color lines in a Line command? I was able to fix most of the issues by installing some missing Gems, but I'm still getting an error that I can't figure out: no such file to load -- http://stackoverflow.com/questions/20693908/cannot-load-such-file-mysql-mysql-api

Mysql Gem Windows

Download the mysql-connector cdn.mysql.com/Downloads/Connector-C/mysql-connector-c-noinstall-6.0.2-win32.zip 2.unzip the zipped file copy the file C:\Users\admin\Downloads\mysql-connector-c-noinstall-6.0.2-win32\mysql-connector-c-noinstall-6.0.2-win32\lib\libmysql.dll in to C:\Ruby193\bin\ paste inside the bin folder. 3. See http://guides.rubygems.org/command-reference/#gem-uninstall about uninstalling command. Log in with Google account | Log in with Yahoo account | Log in with Facebook account No account?

no checking for mysql_query() in -lmysqlclient... Just noticed this. Types and Pattern Matching Type classes Sublime Text Photoshop ? Ruby Mysql2 Example Gradle Spring Lucene ?

Oracle Terms PL/SQL MySQL MongoDB H2 Database Default Javascript Java ? Cannot Load Such File Mysql If you do that, make sure to update your config/database.yml adaptor to use mysql2 instead of mysql. ...and to download libmysql.dll from http://www.mysql.com/downloads/connector/c/ (6.0.2). (1-4/4) Loading... Palindrome polyglot How to make my logo color look the same in Web & Print? http://stackoverflow.com/questions/15301492/mysql-rb6in-r-equire-cannot-load-such-file-mysql-mysql-api-loaderror Report post Edit Delete Reply with quote Re: Having Problem with MySQL Connectivity in Ruby.

Upon mentioning that the mysql gem is deprecated, I decided to try installing the mysql2 gem.... try the solution provided on this blog :- http://blog.mmediasys.com/2011/07/07/installing-mysql-on-windows-7-x64-and-using-ruby-with-it/ share|improve this answer answered Dec 22 '13 at 7:18 DKS 413 Thanks @DKS I followed these instruction and the result There are some solutions mentioned if you google libmysql.dll. Reload to refresh your session.

Cannot Load Such File Mysql

I installed the current XAMPP package for a simple MySQL installation and a decent admin. OpenGL SWF GLSL Algorithm Python .NET Emacs Haskell ? Mysql Gem Windows I'm asking because I can't seem to install the Gem, and I'd like to know if that's really the problem before spending a lot of time trying to install it. Cannot Load Such File Mysql2 My plan was to build me a simple GUI that connects to a core, which in turn connects to a MySQL database that I have prepared ahead of time.

The problem must be simple, but I am going nuts. http://ecoflashapps.com/cannot-load/firedac-phys-mysql.html RE: What does "no such file to load -- mysql" mean? - Added by Trevor Harmon over 4 years ago That was indeed the problem. I installed Ruby 2.0, got the new Glade and GTK up, and Visual Ruby. I have attempted several different approaches to fix this problem and now I am turning to the experts. Ruby Mysql Gem

yes checking for rb_hash_dup()... You have already activated rake 10.1.1, but your Gemfile requires rake 10.0.3. Category PHP ? have a peek here Gems can be maintained by a command line tool called `gem'.

Check the mkmf.log file for more details. PHP regular expression C++ ? The different twins How to import someone else's toolbox?

mysql ruby-on-rails ruby ruby-on-rails-3 share|improve this question edited Dec 20 '13 at 0:16 Justin Wood 3,58321230 asked Dec 19 '13 at 23:49 user2942719 1 try gem install mysql2 -- --with-mysql-dir=c:\RailsInstaller\Ruby1.9.3\bin

It Works for me at Wim 10. I didn't tested but at http://dev.mysql.com/downloads/connector/c/ you should find the installer for your platform. You signed out in another tab or window. It tries to load missing library `mysql_api' which is compiled as a gem's extension at installation.

I read the readme and followed the instructions under Windows clinically yet when I typed in "gem install mysql2 -- --with-mysql-dir=c:\mysql-connector-c-6.1.2-winx64" I got that error message once more "ERROR: Error installing no *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. How to react? Check This Out I tried DBI, that didn't work.

This is similar to sparklemotion/sqlite3-ruby#82 You can force compilation by adding --platform=ruby during gem installation Refer to the following post on how to use Connector/C to compile mysql gem: http://blog.mmediasys.com/2011/07/07/installing-mysql-on-windows-7-x64-and-using-ruby-with-it/ luislavena Why did the best potions master have greasy hair? Now it will work fine. How to decide between PCA and logistic regression?