Home > Cannot Locate > Cannot Locate Alien/package/deb.pm In @inc

Cannot Locate Alien/package/deb.pm In @inc

share|improve this answer edited Oct 6 '14 at 16:26 answered Oct 6 '14 at 15:17 i alarmed alien 5,63721632 This should be preferred in windows only. All of the prerequisite packages (includingAlien::wxWidgets) install fine, but the Wx package itself gets thislink error:LD_RUN_PATH="/lib:/usr/lib:/usr/local/lib/perl5/site_perl/5.12.1/i686-linux/Alien/wxWidgets/gtk_2_8_10_uni/lib" g++ -shared -fPIC -shared -O2 -L/usr/local/lib -fstack-protector Media.o -o ../../blib/arch/auto/Wx/Media/Media.so \-L/usr/local/lib/perl5/site_perl/5.12.1/i686-linux/Alien/wxWidgets/gtk_2_8_10_uni/lib -lpthread -lwx_gtk2u_media-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu-2.8 Ubuntu / Debian always put their own files in/usr and /usrl/local is reserved for stuff you compiled yourself.That's actually a good reason *not* to use the package manager.Lots of system packages This includes the command-line utilities, as well as the C and C++ APIs. http://ecoflashapps.com/cannot-locate/cydia-cannot-locate-package-ios-9.html

Adv Reply March 9th, 2013 #7 schragge View Profile View Forum Posts Private Message Iced Blended Vanilla Crème Ubuntu Join Date Feb 2013 BeansHidden! Every path in your @INC is /usr/loca/lib/*. Powered by vBulletin Version 4.2.2 Copyright © 2016 vBulletin Solutions, Inc. So, to make that work as a user, look in your home directory, try to figure out where it put stuff, and then add a line like this near the top http://www.linuxquestions.org/questions/linux-newbie-8/cannot-use-software-alien-4175486849/

A summary of the changes between this version and the previous one is attached. Everyone has their own idea of what should be in Perl based on what they do with it. Code: [email protected]:~/maya$ fakeroot alien -kv Maya2011_0-docs_en_US_64-2011-88.x86_64.rpm LANG=C rpm -qp --queryformat %{NAME} 'Maya2011_0-docs_en_US_64-2011-88.x86_64.rpm' LANG=C rpm -qp --queryformat %{VERSION} 'Maya2011_0-docs_en_US_64-2011-88.x86_64.rpm' LANG=C rpm -qp --queryformat %{RELEASE} 'Maya2011_0-docs_en_US_64-2011-88.x86_64.rpm' LANG=C rpm -qp --queryformat %{ARCH} 'Maya2011_0-docs_en_US_64-2011-88.x86_64.rpm' LANG=C Code: package Alien; our $Version="8.78"; use strict; use Getopt::Long; use Alien::Package::Deb; use Alien::Package::Rpm; use Alien::Package::Tgz; use Alien::Package::Slp; use Alien::Package::Pkg; use Alien::Package::Lsb; The line 296 is use Alien::Package:eb; I could move the

It's not unusual to have three or four different perls installed. Homepage: http://kitenet.net/~joey/code/alien/ jdk jdkaye View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by jdkaye Thread Tools Show Printable Version Email this Page There's something to be said for struggling though these situations to earn your spurs. Debian distribution maintenance software pp.

Ubuntu / Debian always put their own files in /usr and /usrl/local is reserved for stuff you compiled yourself. Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search permalinkembedsaveparentgive gold[–]VirtualWolf 1 point2 points3 points 1 year ago(1 child)Yep, the system Perl on both my Mac and CentOS box are sitting there quite happily, nothing uninstalled, and all I use is the http://www.multipole.org/discourse-server/viewtopic.php?t=25912 But many *other* things that we do to our local perl installations might *not* play nice with the system perl, which is why we *have* a local perl.

permalinkembedsaveparentgive gold[–]linuxphoney[S] 0 points1 point2 points 1 year ago(7 children)No, that's the error I got when i tried to install it. Just starting out and have a question? So the philosphy is that users should simply install the modules either from CPAN of from the distribution repository. I tried it, but I got the same error message. 0:00:08 Reply With Quote 10-18-2001,03:34 AM #4 Gnu/Vince View Profile View Forum Posts Visit Homepage Registered User Join Date Mar 2000

Thanks fitlad View Public Profile Find all posts by fitlad #9 26th July 2008, 11:17 PM leigh123linux Guest Posts: n/a Quote: Originally Posted by fitlad I tried your see it here This page intentionally left blank. Lots of system packages depend on perl, so most modern *nix distros come with a basic perl set up with predictable settings. Creating symlink for a file on Windows 7 gives error Why does the Minus World exist? "Carrie has arrived at the airport for two hours." - Is this sentence grammatically correct?

Since CentOS is basically RedHat, it also breaks this behavior. http://ecoflashapps.com/cannot-locate/cannot-locate-package-cydia-5-1-1.html That makes nosense.Daniel.--Intolerant people should be shot. All rights reserved.REDDIT and the ALIEN Logo are registered trademarks of reddit inc.πRendered by PID 22860 on app-571 at 2016-11-08 00:14:21.958559+00:00 running 57a3e5e country code: US. The whole modern Perl movement is a pushback against the catch 22 of only having 15 year old perls available and so writing code for them.

Code of Conduct: Be civil or be banned. Maybe there is a separate -dev package just forthe wx media libraries?Hello Mattia,Bah, this is embarrasing! This is pretty easy when using e.g. Check This Out RedHat was, up to very recently, distributing a version of Perl ten stable releases behind.

poblano Using Fedora 1 29th August 2008 03:48 AM WMA to MP3 conversion leigh123linux Using Fedora 0 19th November 2006 02:31 AM VHS to VCD conversion iamroot Wibble 10 4th May Debian, for instance, has a dedicated and vocal group of people who make Perl and CPAN packages that its users can install like all the other software they would install. All of this used to be so much easier when people had to setup their own unix machine because they knew they had to install extra stuff, choose packages, and so

reply | permalink Adam Witney I have to agree with Eric here.

Reply With Quote 10-21-2001,03:20 PM #13 8 View Profile View Forum Posts Registered User Join Date Oct 2001 Posts 65 Thanks much everybody. 0:00:08 Reply With Quote Quick Navigation Window/Desktop Managers Seems it needed several others to run. Try this: yum install perl-devel Then try that again. I would suggest re-installing Red Hat.

For some reason, I was missing libtiff.so.3 and all attempts to link libtiff.so.4 or another library were in vain. Could someone tell me the purpose of this library so that I could look at the package's descriptions to find the right one? By that I mean when I type alien it is telling me it cannot locate the Deb.pm file. this contact form Full text and rfc822 format available.

Try this F9 rpm. Same for Ruby and Python. There is also a requirement for having libaio1. The package manager I encountered on a linux distribution I don't normally use falls out of favor, or Apple makes the developer tools a separate download.

However, the rpm in your output is named Maya2011*.rpm Are you sure you've downloaded the right tarball? I guess it depends on whatelse you are doing with your Perl that could break it.So it should be possible to install any CPAN module on anyinstalled perl on the system. How to make figure bigger in subfigures when width?