Home > Cannot Locate > Cannot Locate Locale/gettext.pm

Cannot Locate Locale/gettext.pm

Install one of them with perlbrew install . Prerequisite modules not found for non-root user Hi, I'm a non-root user trying to use IkiWiki on an academic webserver with Perl 5.8.8 but several missing modules, so I grab them Just today I noticed the "Bundle" subdirectory. This solution is hackish, may come back to bite you in the future, but if it works might be the fastest way to get those applications going. have a peek here

Warning: prerequisite CGI::Session 0 not found. Thanks!Comment on Perl version issue?Select or Download Code Replies are listed 'Best First'. Results 1 to 1 of 1 Thread: Inablity to emerge help2man prevents world update Thread Tools Show Printable Version Email this Page… Subscribe to this Thread… Display Linear Mode Switch to If it does, hard code the path into your startup script, possibly at line 1147 of the file listed in the error.

If you can't fix it, this problem could probably be worked around by unsetting all environment variables when running ikiwiki (LANG, LC_ALL, LC_MESSAGES). This link helped me solved the problem, though the different comments had me confused or reluctant to try any of the suggestions. What version of perl is this, and what version of what distribution? --Joey $ perl -V Summary of my perl5 (revision 5 version 8 subversion 8) configuration: osname=linux, osvers=2.6.22, archname=i586-linux-thread-multi uname='linux Compilation failed in require at /usr/share/perl5/vendor_perl/Gscan2pdf/Document.pm line 13.

Full text and rfc822 format available. How do I use this? | Other CB clients Other Users? This is the best fix of the three.Perlbrew is a great way to accomplish the latter fix. Then you can run ~/bin/ikiwiki --Joey perl Makefile.PL INSTALL_BASE=$HOME PREFIX= make make install 03 September 2010, Report on successful manual install in Debian 5 (Lenny) AMD64: note: Maybe much more easy

First, you previously altered your system perl in order to install Locale:gettext. then I also installed the package perl-Locale-gettext after which gscan2pdf has started successfully.. You need to change this line in debian/control: Depends: debconf (>= 1.3.11), ${perl:Depends} to become: Depends: debconf (>= 1.3.11), ${perl:Depends}, liblocale-gettext-perl As we are currently attempting to get sarge ready for http://www.perlmonks.org/?node_id=1105009 Then it won't try to load Locale::gettext at all. --Joey I am trying to install Ikiwiki version 2.1 from the source tarball.

CORRECTION 1: I played around with CPAN and got the installation to the point of succeeding with >99% of tests in "make test". PerlMonks FAQ Guide to the Monastery What's New at PerlMonks Voting/Experience System Tutorials Reviews Library Perl FAQs Other Info Sources Find Nodes? Reload to refresh your session. node historyNode Type: perlquestion [id://1105009]Approved by farangFront-paged by boftxhelp Chatterbox? and all is quiet...

by farang (Chaplain) on Oct 26, 2014 at 23:38EDT 'perl -v' shows version 5.18. read the full info here no checking for msgfmt... /usr/local/bin/msgfmt checking for gcc... make[3]: *** [asn1Coding.1] Error 2 Can't locate Locale/gettext.pm in @INC (@INC contains: /etc/perl /usr/local/lib64/perl5/5.16.3/x86_64-linux /usr/local/lib64/perl5/5.16.3 /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.16.3/x86_64-linux /usr/lib64/perl5/5.16.3 .) at /usr/bin/help2man line 28. We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

Make it hot by striking - WB Yeats [reply] Re: Perl version issue? navigate here make[3]: *** [asn1Parser.1] Error 2 make[3]: *** Waiting for unfinished jobs.... Follow these steps, and don't type "sudo" in any of them. configure:1816: result: no configure:1821: checking for msgfmt configure:1839: found /usr/bin/msgfmt configure:1851: result: /usr/bin/msgfmt configure:1868: checking for i686-pc-linux-gnu-gcc configure:1884: found /usr/bin/i686-pc-linux-gnu-gcc configure:1895: result: i686-pc-linux-gnu-gcc configure:2164: checking for C compiler version configure:2173: i686-pc-linux-gnu-gcc

Thank you for reporting the bug, which will now be closed. There is no ./IkiWiki.pm file It's interesting that you say you have no ./IkiWiki.pm file, since one is included in the tarball. When you build ikiwiki, try doing it like this to make it install to your home directory. Check This Out Message #10 received at [email protected] (full text, mbox, reply): From: Stephen Quinney To: [email protected] Subject: Missing Depends on liblocale-gettext-perl Date: Fri, 24 Sep 2004 15:34:29 +0100 [Message part 1 (text/plain,

Many thanks to Stephen Quinney for the last update; closes: #273101 * Translations - Brazilian Portuguese thanks to Andre Luis Lopes; closes: #264091 - French thanks to Julien Louis; closes: #264342 BEGIN failed--compilation aborted at /usr/bin/help2man line 28. so perl-Locale-gettext should be an automatic dependency for gscan2pdf?

If I found the source code for the Universe, the first thing I'd do: Fix all the bugs Add a backdoor Remove any backdoors Make clean; make install Make myself root

How can I go about fixing my issue with t-prot finding the needed getttext piece(s) it's looking for? In Makefile.PL, use perl to bump ikiwiki.spec instead of sed -i. Several errors have disappeared by installing more Perl stuff (specifically XML::SAX) XML::SAX is a requirement of XML::Simple, which is a documented build requirement. (Only really needed if you'll be using subversion Do not wait to strike when the iron is hot!

that was system perl. The command perlbrew list should show you which perls are installed under perlbrew, and just perlbrew by itself shows a help screen when it's installed.[reply] Re^4: Perl version issue? Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. this contact form Yes, that bug is already fixed in subversion for the next release --Joey However I'm still getting the following error in 'make test':- t/pagename.................ok t/pagespec_match...........ok 1/52Modification of a read-only value attempted

o checking whether we are using the GNU C compiler... I am using mutt with t-prot and getting the following error when attempting to view a message in mutt (which invokes t-prot) 'Can't locate Locale/gettext.pm in @INC (you may need to What a moron I am! The error I get from the various cpan attempts is basically always the same: Warning: Cannot install Bundle::IkiWiki, don't know what it is.

I wasn't noticing the case of the filename, I'd missed the upper case W and guess what 'find' shows me:- /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki.pm Removing the above file has fixed my basic problem, now Last modified: Tue Nov 8 00:20:14 2016; Machine Name: buxtehude Debian Bug tracking system Copyright (C) 1999 Darren O. every f'in day. TheDoctorsLife Benjamin Hoffmeyer GPG key ID: 47A5324A5BD8E2AB Learn about signing commits 59f229f Sign up for free to join this conversation on GitHub.

Then when I go into the directory where I untarred IkiWiki and try to run the Perl makefile: cd ~/ikiwiki; perl Makefile.PL PREFIX=$HOME/ikiwiki I get warnings that all the modules needed What was the magic CPAN rune that worked for you? --Joey An attempt of "make install" failed while trying to put files in /etc/IkiWiki but per the output's instructions, I reran In Makefile.PL, specify more portable options to cp. rendering todo/calendar_--_archive_browsing_via_a_calendar_frontend.mdwn make: *** [extra_build] Segmentation fault So, perl on your system is segfaulting when running ikiwiki.

Code: configure:1771: checking for perl configure:1776: ...version 5.008 required configure:1785: trying perl found version 5.012 configure:1794: result: perl configure:1804: checking for module Locale::gettext Am I on the right track? Is that section of the page still accurate? -- Jon Are you running perl with the environemnt settings specified on the page? Can't locate Locale/gettext.pm in @INC (@INC contains: /etc/perl /usr/local/lib64/perl5/5.16.3/x86_64-linux /usr/local/lib64/perl5/5.16.3 /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux /usr/lib64/perl5/vendor_perl/5.16.3 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.16.3/x86_64-linux /usr/lib64/perl5/5.16.3 .) at /usr/bin/help2man line 28. Terms Privacy Security Status Help You can't perform that action at this time.

Warning: prerequisite Text::Markdown 0 not found.