Home > Cannot Obtain > Cannot Obtain Lock On Media .hal-mtab Backtrack 4

Cannot Obtain Lock On Media .hal-mtab Backtrack 4

Sebastien Bacher (seb128) wrote on 2007-03-28: Re: (feisty) unmounting a device icon on desktop gives an error dialog #2 Thank you for your bug. Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search registered linux user #438335 Adv Reply February 8th, 2010 #5 jack5964 View Profile View Forum Posts Private Message First Cup of Ubuntu Join Date Feb 2010 Beans 1 Re: Failure vetkasi Using Fedora 6 10th June 2009 10:18 PM creating lock file in /var/lock/subsys gold Using Fedora 1 19th December 2007 05:15 PM How to obtain FC srpms? this contact form

Patching hal properly is too intrusive at this point. (LP: #101845, LP: #95368) -- Martin Pitt

Arch Linux HomePackagesForumsWikiBugsAURDownload Index Rules Search Register Login You are not logged in. This generates the following error message: " can't find /disk in /etc/fstab or /etc/mtab" The same problem occurs if I try to mount a usb pen drive. Martin Pitt (pitti) on 2009-01-27 Changed in hal: status: In Progress → Triaged Felipe Figueiredo (philsf) wrote on 2009-03-27: #35 dot hal-mtab from /media Edit (197 bytes, application/x-trash) I found this To start viewing messages, select the forum that you want to visit from the selection below.

The help and man commands. Upon opening them I got this error message: "Unable to mount the volume" "Cannot obtain lock on /media/.hal-mtab" I've also tried mounting them as root by typing "sudo mount /disk". I am class 12 student and keen to learn and use Linux. Setup: Acer Aspire One Ubuntu 8.10 I hope I've provided you with enough information and thank you in advance for the much needed help tolle66 View Public Profile View LQ

Mark Junker (mjscod) wrote on 2007-09-25: #13 I had the same problem with Gutsy Gibbon. This happens for me with any disk that mounts to /media/disk. How can I find out? 03-26-2009,11:36 PM #4 Archangel-Amael View Profile View Forum Posts Super Moderator Join Date Jan 2010 Location Somewhere Posts 8,010 Originally Posted by fergzcm Thanks for this. Check This Out You are currently viewing LQ as a guest.

This generates the following error message: " can't find /disk in /etc/fstab or /etc/mtab" The same problem occurs if I try to mount a usb pen drive. IMHO /media/.hal-mtab should move to /var/run/hal-mtab, and in addition we should apply a fixed version of this patch. mkdir /mnt/sr0 #for mounting DVD/CD Drive add the USB device/HDD Partition/DVD/CD entries to /etc/fstab for example if its sdb1 it should look like nano /etc/fstab /dev/sdb1 /mnt/sdb1 vfat auto,noatime,users,suid,dev,exec 0 0 I found http://www.linuxquestions.org/questi...a.mtab-694621/ this post and thought it might be related.

Thanks for the work so far, Martin. apocalyptic View Public Profile Visit apocalyptic's homepage! How can I find out? tolle66 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by tolle66 Thread Tools Show Printable Version Email this Page Search this Thread Advanced

Changed in hal: assignee: desktop-bugs → pitti status: Triaged → In Progress Martin Pitt (pitti) wrote on 2008-03-19: #19 Affects quite a lot of people. weblink Using an external usb DD (with NTFS) labeled "Lacie". Add tags Tag help Related branches lp:ubuntu/oneiric/sysvinit Ilmari Vacklin (wolverian) wrote on 2007-03-24: #1 Argh, forgot to mention that the unmounting actually does work, despite the error dialog. Edit bug mail Other bug subscribers Subscribe someone else Patches Skip stale entries in /media/.hal-mtab (edit) Add patch Bug attachments dot hal-mtab from /media (edit) Add attachment • Take the tour

And I had backup .hal-mtab and .hal-mtab-lock , so I restored both files to /media/ but same error, its showing. If this does involve config files, we'll need this to be automatically cleaned up during the upgrade process. Google™ Search FedoraForum Search Red Hat Bugzilla Search
Search Forums Show Threads Show Posts Tag Search Advanced Search Go to Page... navigate here No unused mount points on my system in /media except cdrom and cdrom0 (which if I recall correctly behave a tad differently).

The thing is, I'd like to know what is happening when I do this 'touch /media/.hal-mtab'. I popped them in and they worked just fine. begemot (oival) wrote on 2008-11-27: #34 Hardy 8.04.1 is infected for me too.

It does seem to only happen when there are stale entries in /media/.hal-mtab I'm guessing it was from having multiple drives plugged in.

Patrice Vetsel (vetsel-patrice) wrote on 2008-04-09: #26 Confirmed also with another external USB DD with Ext3 and VFAT partitions Martin Pitt (pitti) wrote on 2008-04-10: #27 This created a regression, see Martin Pitt (pitti) wrote on 2009-05-27: #36 GNOME in Karmic does not use hal for mounting any more, and the sysvinit workaround solved this bug sufficiently. Since then it started giving the same error for my Pen-Drives and External Hard-disk... Quick Navigation OLD BT4beta Bugs and Fixes Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums BackTrack 5 Forums BackTrack 5 Announcements BackTrack 5 Frequently Asked

Affecting: sysvinit (Ubuntu) Filed here by: Martin Pitt When: 2008-04-03 Confirmed: 2008-04-03 Assigned: 2008-04-03 Started work: 2008-04-10 Completed: 2008-04-14 Target Distribution Baltix BOSS Juju Charms Collection Elbuntu Guadalinex Guadalinex Edu Kiwi Here's what happened when I tried: [email protected]:/$ sudo rm /var/run/dbus/pid [email protected]:/$ sudo dpkg-reconfigure hal * Stopping Hardware abstraction layer hald [ OK ] * Reloading system message bus config... [ OK Join our community today! http://ecoflashapps.com/cannot-obtain/cannot-obtain-lock-on-media-hal-mtab-gentoo.html FAQ Forum Quick Links Unanswered Posts New Posts View Forum Leaders FAQ Contact an Admin Forum Community Forum Council FC Agenda Forum Governance Forum Staff Ubuntu Forums Code of Conduct Forum

Topics: Active | Unanswered Index ┬╗Applications & Desktop Environments ┬╗Unable to mount media: "Cannot obtain lock on /media/.hal-mtab" Pages: 1 #1 2007-11-20 19:04:37 RazZziel Member From: Spain Registered: 2007-07-13 Posts: 35 Mark as duplicate Convert to a question Link a related branch Link to CVE Duplicates of this bug Bug #85424 Bug #91854 Bug #114326 You are not directly subscribed to this Changed in sysvinit: importance: Medium → High milestone: none → ubuntu-8.04 status: Confirmed → In Progress Martin Pitt (pitti) wrote on 2008-04-14: #28 I reverted the sysvinit change which caused this