Home > Cannot Open > Cannot Open /usr/lib/httpd/build/config_vars.mk

Cannot Open /usr/lib/httpd/build/config_vars.mk

falko, Jun 16, 2009 #2 etpoole60 New Member HowtoForge Supporter Yes sir. Stop. Bad misbehavior like this may qualify as a "bug". I just entered: system-config-securitylevel And SELinux shows as disabled. this contact form

Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the You should contact your Red Hat rep to open a support case. –Michael Hampton♦ Nov 25 '14 at 13:21 add a comment| 2 Answers 2 active oldest votes up vote 2 Note the following: [[email protected] ~]# yum install httpd-devel Loading "fastestmirror" plugin Loading mirror speeds from cached hostfile * base: mirror.raystedman.net * updates: mirror.sanctuaryhost.com * addons: mirror.newnanutilities.org * extras: mirrors.tummy.com Setting up Since this is a build I can re-do, I searched and found suphp in rpm form.

https://github.com/iuscommunity-pkg/httpd24u/commit/c23a52076fb5b71c7c295151af71a86d84145046 The build httpd24u-2.4.16-2.ius will move to our testing repos during tonight's automation. As far as I know (but I could be wrong), official rpm packages never install into /opt. The rpm package gets built for the system httpd in /etc/httpd and loads rapache from /etc/httpd/modules/mod_R.so. configure: error: Bad apache2 binary (/) ./configure: line 11393: /home/mbacou/rapache-1.2.7/libapreq2/apreq2-config: No such file or directory ./configure: line 11394: /home/mbacou/rapache-1.2.7/libapreq2/apreq2-config: No such file or directory ./configure: line 11395: /home/mbacou/rapache-1.2.7/libapreq2/apreq2-config: No such file

configure: error: Aborting ~0008116 range (administrator) 2008-10-11 12:07 mickh: No, you don't, you are just missing the package which contains apu-1-config. You need to instead do: sudo scl enable httpd24 perl516 'make install' share|improve this answer answered Mar 6 '15 at 21:15 Justin Dearing 760627 add a comment| Your Answer draft Browse other questions tagged apache-2.2 redhat or ask your own question. But when i try to make "make install" I get the following: /usr/local/sbin/apxs -i -a -n php4 libphp4.la /usr/local/build/instdso.sh SH_LIBTOOL='/usr/local/build/libtool' libphp4.la /usr/local/libexec sh: /usr/local/build/instdso.sh: No such file or directory apxs:Error: Command

make[1]: Leaving directory `/home/mbacou/rapache-1.2.7/libapreq2' make[1]: Entering directory `/home/mbacou/rapache-1.2.7/libapreq2/library' make[1]: *** No targets specified and no makefile found. jeffreyhorner closed this Aug 4, 2015 rapache collaborator jeroenooms commented Aug 4, 2015 I don't have a linux box right now but you need to build rapache using something like: ./configure Here is the fix for el7 and minor fix on el6: [weli@localhost jws-compose]$ git diff diff --git a/jws-compose.spec b/jws-compose.spec index acc125f..e5812a6 100644 --- a/jws-compose.spec +++ b/jws-compose.spec @@ -266,7 +266,10 @@ sed https://lists.centos.org/pipermail/centos-devel/2008-June/002955.html rapache collaborator jeroenooms commented Aug 4, 2015 What is this package called then?

cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201. Name: not available Type: application/pgp-signature Size: 194 bytes Desc: not available URL: Previous message: [CentOS-devel] CentOS Forums again Next message: [CentOS-devel] apr-devel and httpd-devel packaging problem Messages sorted by: [ TagsNo tags attached.Attached Files Relationships related [email protected] Testing tracking bug: Report all problems here. It then goes on to install apr-devel - but the i386 version.

Ballpark salary equivalent today of "healthcare benefits" in the US? Same goes for the 64bit apr-util-devel package. Once it does please test it and confirm if this fixes your apxs issue. mbacou commented Aug 4, 2015 Thanks Jeroen, yeh I think that's the problem.

The new URL is: http://lists.centos.org/pipermail/centos-devel/2008-June/002955.html ~0007909 range (administrator) 2008-09-02 17:00 Can the reporter please check if the yum in testing (see note above) fixes that issue, so we can close this http://ecoflashapps.com/cannot-open/cannot-open-config-file-zabbix-agentd-conf.html rapache owner jeffreyhorner commented Aug 4, 2015 That's really strange. Mail about any other subject will be silently ignored. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 22 Star 101 Fork 19 jeffreyhorner/rapache Code Issues 10 Pull requests 0 Projects

Home | New | Browse | Search | [?] | Reports | Help | NewAccount | Log In Remember [x] | Forgot Password Login: [x] Skip to content Ignore Learn cannot open /usr/lib64/httpd/build/config_vars.mk: No such file or directory at /opt/rh/httpd24/root/usr/bin/apxs line 214. The configure-script of php fails with cannot open /usr/local/build/config_vars.mk: No such file or directory at ./apxs line 248. navigate here Since apxs is a perl script if you take a look inside it, this is the responsible code: my $libdir = `pkg-config --variable=libdir apr-1`; chomp $libdir; my $installbuilddir = $libdir .

Yes, my password is: Forgot your password? See apr-devel.x86_64 does not provide apr-devel in a 64 bit version *and* httpd-devel does not require apr-devel in a 64bit version. boatrsp, Jul 23, 2009 #5 (You must log in or sign up to reply here.) Show Ignored Content Share This Page Tweet Log in with Facebook Log in with Twitter Log

mbacou commented Aug 4, 2015 I had some locked files left from previous failed make, sudo make clean fixed that. @jeroenooms I suppose I also need to config make install opencpu

Thanks for your report, and thanks for using Apache! Started with exact problem described above. share|improve this answer edited Nov 25 '14 at 13:54 answered Nov 25 '14 at 13:49 Jakov Sosic 3,2821616 This is a bad idea. Can dispel magic end a darkness spell?

How to import someone else's toolbox? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Thank you! his comment is here cannot open /usr/lib64/httpd/build/config_vars.mk: No such file or directory at /opt/rh/httpd24/root/usr/bin/apxs line 214.

Terms Privacy Security Status Help You can't perform that action at this time. https://groups.google.com/forum/#!topic/rapache/yFP1t2yPOCc mbacou commented Aug 4, 2015 That worked. I double-checked SELinux, and here too it's disabled. Comment 6 Dan Muller 2002-06-01 07:12:52 UTC I also ran into this, with an Apache build I did on a Debian system from latest sources.

apache-2.2 redhat share|improve this question edited Nov 25 '14 at 13:10 asked Nov 25 '14 at 9:42 Fractaliste 1216 This may be a problem with the way that it How Did The Dred Scott Decision Contribute to the Civil War? You need something like: ./configure --with-apache2-apxs=/opt/rh/httpd24/root/usr/bin/apxs See also chapter 2.1 Building from source from the rapache manual. cannot open /usr/lib64/httpd/build/config_vars.mk: No such file or directory at /opt/rh/httpd24/root/usr/bin/apxs line 214.

When I launch the command apxs --help I get the following error: cannot open /httpd/build/config_vars.mk: No such file or directory at /opt/rh/httpd24/root/usr/bin/apxs line 214 I locate this file into /opt/rh/httpd24/root/usr/lib64/httpd/build/, should I configured php with following command: ./configure --with-tsrm-pthreads --with-mysql=/usr/local --with-imap-ssl=/usr/local --with-gettext --with-imap=/Source/imap-2001a --with-gd --with-openssl=/usr/local --with-apxs2=/usr/local/sbin/apxs and apache 2.0.35 with the following: ./configure --enable-layout=GNU --enable-info --with-ssl=/usr/local --enable-so Comment 1 Stephan W 2002-04-24 Where do I drop off a foot passenger in Calais (P&O)? 40 Vertices And A Connected Graph, Minimum Number Of Edges? Now there is another error when I start apache: Syntax error on line 218 of /usr/local/etc/apache2/httpd.conf: Cannot load /usr/local/libexec/libphp4.so into server: /usr/local/libexec/libphp4.so: undefined symbol: ssl_onceonlyinit sbin/apachectl start: httpd could not be

mbacou commented Aug 4, 2015 That said, I didn't build apache 2.4 manually, just a standard yum install from EPEL. Recap: $ scl enable httpd24 bash # prepends /opt/rh/httpd24/root/usr/bin:/opt/rh/httpd24/root/usr/sbin: to $PATH $ ./configure --with-apxs=/opt/rh/httpd24/root/usr/bin/apxs $ sudo make clean $ sudo scl enable httpd24 'make install' [...] Libraries have been installed in: A workaround for this to symlink the *.pc files, like so: $ ln -s /usr/lib64/pkgconfig/apr15u-1.pc /usr/lib64/pkgconfig/apr-1.pc Extra details: $ uname -a Linux www.jci.dev 2.6.32-504.1.3.el6.x86_64 #1 SMP Tue Nov 11 17:57:25 UTC hopefully.

cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201. But if you make sure there is only a single version of httpd installed on the machine, the configure script will probably pick it up so you don't have to manually It uses pkg-config to get the libdir of the apr-1 package, as follows: my $libdir = `pkg-config --variable=libdir apr-1`; This returns an empty string if you have apr15u-devel installed, because its Edit bug mail Other bug subscribers Subscribe someone else • Take the tour • Read the guide © 2004-2016 CanonicalLtd. • Terms of use • Contact Launchpad Support • Blog